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Browsers are windows to the World Wide Web and they allow you to view and interact with a wealth
of information presented as text, images, animations, video, and audio. The creation of web browser
software transformed the Internet from a text-based realm to a multimedia one that continues to
rapidly grow and evolve.

Becoming proficient at web browsing is a fundamental skill for anyone in our contemporary times,
but perhaps even more so for educators. As facilitators of the learning process, educators must
become technology literate and proficient at accessing, acquiring, managing, and applying informa-
tion resources that can be applied in support of learning. It is likely the Web will continue to expand
and serve a central role in our communication, information sharing, and learning.

•To develop familiarity using Microsoft Internet Explorer
•To develop skills and techniques for browsing the Web

Prerequisites
Teachers should be familiar with the basic operating system of their computer including use of
mouse, disks, and file management. This module also assumes your computer is connected to the
Internet through either a dialup or network connection, and that the connection is active.

Glossary
The following terms and definitions are useful to know for this module:

Internet
A series of networks that link computers and servers all over the world.

IE
The casual abbreviation for Internet Explorer

Browser
The software that allows you to use the Internet with a graphical interface.

Web site
A set of electronic web pages that contains textual, graphic, audio, and/or video information.

Search Engine
A web site designed to help you locate information on the Internet more easily comprised of a
combination of bots that comb the web indexing web content and extremely powerful databases
that manage the information.

URL
The unique address used to locate a web site on the Internet.
Example: http://www.kodak.com

Overview

Objectives
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Welcome to Internet Explorer
Now that your new classroom technology is set up and ready to use, you are ready to become an
efficient Internet user. Being able to use the Internet efficiently will help you enhance teaching and
learning in your classroom. Your new PC’s come preinstalled with Internet Explorer 5.0 web
browser software. These training materials will walk you through a series of information and steps
to increase your skills as an Internet user.

Locating and Opening Your Internet Explorer Application
To begin browsing the Internet you must first be able to open your Internet Explorer application.
There are a number of places where you can find an Internet Explorer icon to click and open the
IE browser.

Open Internet Explorer from the Desktop
When Internet Explorer is installed, copies of its application icon are placed in several places,
including the desktop.

1. Locate the Internet Explorer icon on your desktop. -click your hard drive icon.

Desktop Internet Explorer Icon

2. Double-click the icon. The Internet Explorer browser window opens.

Open Internet Explorer from the Taskbar
Another location where Internet Explorer has installed a copy of its application icon is the
Taskbar.

1. Locate the Internet Explorer icon in your Taskbar.

Internet Explorer Icon in Taskbar

2. Click the icon. The Internet Explorer browser window opens.

Open Internet Explorer from the Start Menu
When any program, including Internet Explorer is installed in Windows 98, an icon for the
program is placed in the Programs folder in the Start Menu. This is yet one more place where
you can open Internet Explorer.

1. Click the Start Menu then point to Programs. A submenu with installed programs opens.
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Opening Internet Explorer from the Programs Menu

2. Click the icon. The Internet Explorer browser window opens.

Similarities to Netscape
Internet Explorer and Netscape Communicator are the two main web browsers used in schools,
business, and  for personal use. Internet Explorer is a Microsoft product, and Netscape is owned by
AmericaOnline.

                             

Internet Explorer Logo and Netscape Communicator Logo

While there are many differences between the two browsers, there are also many similarities,
especially in some of the most useful and used functions. As those functions are discussed,
Netscape notes are provided to indicate when Netscape uses different language for a similar useful
function employed by Internet Explorer.

Additionally, Internet Explorer provides a section in its Help menu specifically for Netscape users
who are switching to IE. If you are such a user, you may care to view this section.

Help for Netscape Users

Browsing Methods
Browsing is an interesting term used to describe the actions you take while gathering information
on the Internet. Browsing really consists of two actions. The first action is the viewing of a web
page or the contents of a web page. The second action is the navigation through and between a
series of web pages that make up one web site or a series of web sites.

Internet Explorer provides a number of different browsing or navigational methods to help you
find the information you need.

Linked Text
Almost all pages on the Internet have some kind of text that has a built-in link to another page on
the Internet, unless it is all graphics or is designed to automatically jump to another page after so
many seconds.  This type of text is called linked text, hypertext, or hyperlinks.
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1. When you move the cursor across a piece of text that has been highlighted with a special
color, usually blue, a white hand appears indicating that the text you are pointing to is a linked
text and will take you to a new page when clicked.

Cursor Pointing to Mail link

To visit the new web page indicated by the highlighted text, simply click once while the white
hand is pointed at the highlighted text.

Linked Images
Many pages on the Internet also have linked images that have built-in links to other pages on the
Internet.  These linked images function much the same way as linked text.

1. When you move the cursor across an image that has been linked, a white hand appears
indicating that the image you are pointing to is a linked image that will take you to a new page
when clicked.

Cursor Pointing at Apple Logo

2. To visit the new web page indicated by the linked text, simply click once while the white
hand is pointed at the image.

3. It is rarely obvious that an image is linked unless text is used along with the image that
shows you it is linked. Therefore, you need to get into the habit of running the cursor over
images to find out if they are linked or not. Many logos on web pages are linked to return you to
the home page of the web site. For example, when you click the LAUSD logo, you are returned
to the LAUSDNet home page.

Los Angeles Unified School District Logo

Address Bar
Another method used to browse or navigate to another page is the Address Bar. Internet
Explorer’s Address Bar is located just under the Standard Buttons toolbar at the top of the page.
This method is good to use when you already know the web address or URL of a web site or
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page that you would like to visit.

You may have found an address in the newspaper, a magazine, seen it on TV, or had a friend
email you the address. However you obtained the address, the Address Bar is the place to go to
help you find the page quickly.

1. Locate the Address Bar at the top of the Internet Explorer page.

2. If the Address Bar already contains a URL, take your cursor and drag through and highlight
the existing address.

3. If there is no existing address, click your cursor in the Address Box.

4. Type the URL of the web page you would like to visit. For example, you might enter:
www.yahoo.com.

5. You now have the option to press the Return Key or click the Go button at the right end of
the Address Bar. After you click, you are taken to the web site of the address you entered.

Go Button in Address Bar

 Netscape Note: In Netscape, the Address Bar is called the Location Bar.

Forward and Back Buttons
You can also use the Forward and Back buttons on the left end of the Standard Buttons to move
one page forward or one page backward. When you first open Internet Explorer the Forward and
Back buttons will not be available for use, because you haven’t visited any sites yet.

Back and Forward Buttons

After you have visited at least one page, you can use first the Back button, then the Forward
button.

1. If you just opened Internet Explorer for the first time in a session, you will need to visit at
least one page before having access to the Back Button. Click a link or type in an address in the
Address Bar to visit a new page.

2. Now you will see the Back Button highlighted at the left of the Button Bar. Click the Back
button once to return to the first page.
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Back Button Highlighted

3. Now that you have one other page you have visited in addition to the first page, the Forward
button is now highlighted. Click the Forward button to return to the page you just came from.

Forward Button Highlighted

4. As you visit more and more web pages, you will be able to use the Back and Forward buttons
as often as you like to return to pages you have recently visited.

5. Note that when you press the small triangle to the right of each button, you will see a pop-up
menu of visited sites available for repeat viewing in that direction. You can “jump” to any of
these sites by pointing to its name and clicking. Using this feature can reduce the number of
mouse clicks needed to return to a web page compared to clicking either the Back or Forward
button repeatedly and moving through the visited pages sequentially, one at a time.

Opening More than one Browser Window
Many occasions call for having more than one browser window open at the same time. You may
want to compare some text or images on one page to those on another page. Or you may be
taking an online course where your training materials appear in one window, but your applica-
tion appears in another.

1. Open Internet Explorer using any of the previously described methods. The Internet Explorer
opens with a web page in view.

2. With the first window open, choose New Window from the File Menu.

Selecting a New Browser Window from the File Menu

3. A second window opens on top of your first window. Position the two windows so that you
can click either window. One will be in the foreground and one will be in the background.

4. Toggle back and forth between the two windows as needed simply by clicking either page.

5. You can continue to open additional windows as needed.
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Opening a Link in a New, Separate Window
The PC mouse has two buttons. When you press the right one, called right-clicking, you get a
“pop-up” or contextual menu. You can execute many common commands from this menu.
Depending on where you point, you get different contextual menus, hence the name. When you
point to a link and right-click, the contextual menu provides options related to the link, including
the option to open it in a new window.

Internet Explorer Contextual Menu for a Link

1. Point to a link you want to open in a separate window.

2. Right-click and select Open in New Window from the contextual menu.

3. The linked page opens in a separate window in front of the window containing the original
link.

Managing Multiple Open Windows
The Windows operating system provides two convenient options for arranging multiple open
windows. The commands for arranging open windows can be easily accessed by right-clicking the
Taskbar on its gray background then selecting from the contextual menu.

Taskbar Contextual Menu
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To easily be able to compare two open browser windows, you can “tile” them.

1. With two browser windows open, right-click the Taskbar on its plain, gray background.

2. From the contextual menu select Tile Windows Vertically.

3. The two open windows now appear side by side for comparison viewing.

With numerous browser windows open, you might want to arrange them so they “cascade”.

 1. With multiple browser windows open, right-click the Taskbar on its plain, gray background.

2. From the contextual menu select Cascade Windows.

3. The open windows are arranged diagonally from the upper left of the screen to the lower
right, with their title bars just overlapping.

4. This view makes it easy to see the titles of all open windows and to quickly click and select
any open window to bring it to the foreground for viewing.
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Toolbars and Bars
Some of the most useful elements built into the Internet Explorer environment are its toolbars and
other bars. When you open Internet Explorer a number of toolbars and bars are open by default. You
can select which toolbars and bars to view from the View menu.

In this section we will look closely at the functionality of these toolbars and bars.

Standard Buttons Toolbar
By default the Standard Buttons toolbar is located just beneath the Menu Bar below the title for the
open Internet Explorer window. It is the bar we looked at earlier when learning how to use the
Back and Forward buttons to browse through previously visited web pages.

Standard Buttons Toolbar

Stop Button
The Stop button is the next one in the row of buttons reading from left to right following the
Back and Forward buttons. The Stop button can be useful in a few of situations.

Stop Button

1. Click the Stop button if you are in the middle of accessing a web page and you change your
mind.

2. Click the Stop button if it is taking longer than you expected to access a web page.

3. Sometimes when you are trying to print a web page, an animation graphic or other web item
continues to regenerate itself through the source code that drives the web page. When this is
happening you are not able to access the Print function. Simply click the Stop button once, and
you will then be able to print the web page.

Refresh Button
When you click the Refresh button, the Internet Explorer browser revisits the web server the
page was served from and a new, more current version of the page is brought to the window.
While most pages currently on the Internet are static and don’t change rapidly, the Refresh
button can be useful to you in a couple of scenarios.

Refresh Button
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1. Whenever a web page is generating dynamic information that changes often over time,
clicking the Refresh button will open the page. An example of a good use of the Refresh button
is when a sports page that gives a continuous update of scores needs to be revisited often for
accurate scores. Students might use this function for gathering information for live news broad-
casts.

2. Another scenario for using the Refresh button is when you or students are keeping track of
stocks. A variety of web pages allow students to keep portfolios to track simulated stock pur-
chases. The Refresh button allows students to receive up-to-the-minute reports on stock activity.

3. When you get a little more comfortable with the Internet and start building your own web
pages, the Refresh button will become very useful. If you are designing your own web pages and
posting them to a web server, you can click the Refresh button to view your newly posted pages.

 Netscape Note: In Netscape, the Refresh button is called the Reload button.

Home Button
Just as most web sites have a home page, your personal Internet Explorer also has a home page.
The home page is the page that always opens up first when you launch Internet Explorer.

Home Button

No matter how far you have travelled on your Internet journeys, no matter how many pages you
have visited, you can always return to your home page quickly by clicking once on the Home
button.

Print Button
The Print Button allows you one-click access to your Print window, rather than having to choose
the Print command from the File menu.

Print Button

1. Click the Print button to display the Print window.

2. Select the appropriate number of copies and other desired information.

3. Click the Print button on the Print window and your web page will be printed.

Mail Button
The Mail button allows you to send the web page you are viewing to anyone else who also has
email capabilities.
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Mail Button

1. Locate the web page you would like to send to a colleague or friend.

2. Click the Mail button and the default mail client is launched which allows you to enter the
appropriate email information to send the web page.

3. If you click and hold the Mail button the following menu opens, which offers you the option
to read your mail, send a new message, or send a link.

Mail Menu

 In Netscape, you can send a link or page using the Send Page command in the File menu.

Address Bar
The Address Bar, covered briefly in the First Steps section, is one method to browse the Internet by
inputting the URL or web address of your choice.

Address Bar

The Address Bar can be used for additional purposes to help you in your use of the Internet as a
classroom tool.

1. If you are using linked text or linked images to navigate around the Internet and you want to
know the address of the pages you visit, simply look at the Address Bar. The URL of the page is
always displayed there.

2. Another useful function of the Address Bar is the Favorites icon in front of the address. We'll
explore its use in the section on Favorites.

Favorites Icon in Address Bar Window

Status Bar
The Status Bar is at the very bottom of the Internet Explorer window. As the name implies, the
Status Bar lets you know the current status of Internet Explorer.
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When Internet Explorer is displaying a page that is finished loading, the Status Bar reads “Done.”
However, when you run your cursor across linked text or linked images, the Status Bar displays the
web address of the page you would visit if you clicked that link.

Status Bar

When you click the linked text or image to visit another page, the Status Bar will provide a se-
quential description of the process, beginning with an indication that Internet Explorer is connect-
ing to a server, then finding the page, then downloading it, then done.

Explorer Bar
The Explorer Bar is actually a series of three buttons within the Standard Buttons toolbar. It con-
tains the Search, Favorites, and History buttons.

  

Explorer Bar Buttons: Search, Favorites, and History

When you click any of these buttons a separate pane appears at the left of the browser window
with the contents for that button. These buttons also act like toggle switches. When you click once,
the function opens, and when you click the tab again, it closes.

Search
The Search button on the Explorer Bar provides a variety of search options to help you locate
web pages, people, phone numbers, and more.

1. Click the Search tab on the Explorer Bar. The Search pane opens at the left side of the
browser window. The top section of the window contains choices to indicate your search topic.

Top of Search Pane

2. After you have clicked to choose a category for your search, move to the bottom of the pane
and type in any keywords that will help narrow your search.
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Bottom of Search Pane

3. Click the Search button to start the search.

Search Results

4. The search you just performed was done by one search engine. If you would like to look at
the results of other search engines, click the small arrow to the right of the Next button at the top
of the Search pane and select another search engine from the pulldown menu.

Buttons at Top of Search Pane

Next Button with submenu
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5. Different search engines provide different features. For example, using the MSN search
engine for the same search on "curriculum" yields different results. Additionally, it provides you
an option to view summaries of the results by clicking the check box in front of “show result
summaries.”

MSN Search Results on "curriculum" with Summaries

6. To conduct another search, click the New Search button at the top of the Search pane and
enter a new category and new keywords.

7. You can customize your searches by clicking the Customize button at the top of the Search
pane.

Customize Search Settings

8. The Customize Search Setting window opens with a series of categories and options. You
can check and uncheck any of the options available. Remember to scroll downward to view all
the available options.
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9. After you have made your selections, click the OK button to return to your Search pane.

10. Click the Search tab to close the Search pane.

Favorites
Favorites are an ever present function of Internet Explorer. The window that appears when you
click the Favorites button has the same layout and functionality as the Favorites Menu. As often
occurs, Microsoft provides more than one place for executing similar or identical commands.
Let’s explore the Favorites function by clicking the Favorites button.

1. Click the Favorites button on the Explorer Bar.

2. The Favorites pane opens at the left of the browser window with a list of favorite links to
web sites.

Favorites Pane

3. The list contains both folders and direct links to web pages. Click a folder and it expands to
show you the list of favorite links within that folder.

4. At the top of the pane, two buttons allow you to Add or Organize your Favorites. When you
click the Add button, the Add Favorite window opens.
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Add Favorite Window

5. Navigate to an existing folder and click to select it as the destination for your new favorite or
click New Folder to create a new folder for the favorite. In either case, with the target folder
selected, click the Create In button. The link of the page you are currently visiting is added to
your list of Favorites in your designated location.

6. There is another simple way to add a link to your Favorites collection. Once you have a page
in view that you would like to save as a Favorite, you can drag the small Favorites icon from the
window in the Address Bar and drop it in your open Favorites pane.

7. Press and drag this icon to either the Favorite pane area to add it to the top level, or drag it
over a folder to which you want to add it. The URL will be added as a Favorite for future refer-
ence and use.

8. If you want to organize your Favorites,  click the Organize button at the top of the pane, and
a the Organize Favorites window opens.
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Organize Favorites Window

9. In this window you can create or rename folders, delete folders or individual Favorites, and
move Favorites to new locations. When you select New Folder, a new Untitled Folder appears in
your Favorites pane. Click the folder to highlight the text and rename it as you choose.

10. You can also drag Favorites into any folder by pressing and dragging the individual Favorite
to a new location, either in the Organize Favorites window or in the Favorites pane.

11. Note that you can also "drag and drop" Favorite folders and bookmarks to new locations
directly in the Favorites pane. Press and drag a Favorite or folder to a new location in the list.

12. Click the close box at the top of the Favorites pane to close it.

History
The third button on the Explorer Bar is the History button which provides a chronological list of
all sites you have visited either within a session, within the day, or within past days you used the
browser.

1. Click the History button on the Explorer Bar.

History Button

2. The History pane opens with a list of links in ascending order from when you visited them.

3. If this is your first time using Internet Explorer you will not have any history to track yet.
After you have spent some time using the browser, you will notice a list of links at the top of the
pane that show you where you have been that day.
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History Pane

4. Click any link to revisit a page you previously visited earlier in the day.

5. At the bottom of the pane is a list of folders with time frame labels such as Monday, Last
Week, 2 Weeks ago, Last Month, etc. Inside these folders are the web sites you visited during
those time frames. Click any time frame folder to see the list of links visited in that particular
time frame. Click any of the links to revisit a page you have previously visited.

6. Click the small arrow to the right of the View button in this pane to access a pulldown menu
with a list of options for how you wish to view your History.

View Options in History Pane

7. Click the Search button in this pane to open a Search window which allows you to search
your History by keywords.

8. Click the close box at the top of the History pane to close it.

Viewing or Not Viewing Toolbars and Bars
Internet Explorer allows you to choose which toolbars and bars you wish to have in view based on
your personal preference and browsing habits. Use the View menu to select to view or not view
particular toolbars and bar.
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View Menu

1. Click View then point to the Toolbars or Bar section you want to modify.

2. When you point to Toolbars or the Explorer Bar, you get a submenu, indicated by the small
arrow besides each menu command.

3 A checkmark denotes a toolbar or bar is active and in view. Removing the checkmark dese-
lects the toolbar or bar and removes it from view.

Use this feature to customize the appearance and functionality of your browser window.
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Menus
Every application comes with a set of menus with commands and functions that help you use the
application more effectively. Internet Explorer has eight menus that accompany the many other
functions available directly from the Toolbars within the window.

Many of the functions and commands within the menus are redundant to other functions we have
already discussed. Some of the functions are more advanced than you need to know at this point. It
is necessary to briefly explore another group of menu commands to help you become a successful
Internet user. While we will show you screen shots of the complete menus, we will only address a
few of the functions and commands on each, mostly in narrative format rather than a series of steps.

File Menu
The File Menu for Internet Explorer looks similar to File Menus for other applications.

File Menu
New Window
The New Window command opens a new Internet Explorer window. You can have several
browser windows open simultaneously.

Open File
The Open File command allows you to open HTML documents or images within the browser
window.

Send
The Send command provides you an easy way to email a link or an actual web page file to
someone else using your email client.

Import and Export Favorites
As you build lists of favorites, you can export those links as a file that you can share with others
on disk or through email. Likewise, you can also import favorite files sent to you by others.
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Edit Menu
The Edit Menu is similar to most other applications.

Edit Menu

Find (on this Page)
A useful option in the Edit menu is the Find (on this Page) command. When selected a separate
window opens with a search field. Type a word in the field and click the Find Next button to
search for every occurrence of your word.

Find (on This Page) Window

View
The View Menu provides access to a number of commands that let you alter the look and feel of
the Internet Explorer window and its Toolbars. As covered earlier you can choose which of the
toolbars and bars to have in view by selecting or deselecting them from this menu and the Toolbars
and Explorer Bar submenus.

View Menu

Additionally, you can use other commands in this menu to access which web page to view, and to
change how it appears in your browser.
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Go To
The Go To submenu provides yet another way to navigate. You can access Back and Forward
commands from here as well as your Home Page. You can also backtrack or jump to any site you
have visited in your browsing session by simply pointing to and clicking the name of the page in
the Go To submenu. Note that the page currently in view is denoted by a check mark.

Go To Submenu

Text Size
Additionally you can modify the size of text viewed in your browser window by selecting from
the Text Size submenu. Choose a view ranging from smallest to largest.

Text Size Submenu in View Menu

Full Screen
You can also maximize your view of the browser window by selecting the Full Screen command.
When you do, IE expands the browser window to virtually your entire screen, leaving only a
small, icon-based menu at the upper left and the usual Windows minimize, restore, and close
buttons at the upper right. Click the restore button to return to the typical browser window view.
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Favorites
The Favorites Menu contains the same basic information as the Favorites pane, opened by clicking
the Favorites button in the Explorer Bar. That information includes a list of favorites and the
ability to Add and Organize favorites.

Favorites Menu

Tools
The Tools Menu contains tools for specialized functions that you can learn about through the Help
menu.

Tools Menu
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Internet Options
The Internet Options command is highly valuable. The Internet Options window gives you the
opportunity to adjust the configuration of many of the aspects of your Internet Explorer applica-
tion.

Internet Options Window

Setting Your Browser Home Page
While most of the configurations in the Internet Options take you a little beyond the familiarity
purposes of these materials, we will jump into them briefly to show you how to configure your
browser home page.

1. Your Internet Explorer was installed with a preset browser home page. By using the Internet
Options you can choose any home page you like.

2. Open your Internet Options and click the General tab to ensure its card is in the foreground.

3. You will see a section at the top labeled Home Page. Note the current address in the address
field.



 Internet Explorer 5.0 for PC 26

Home Page Section on General Card in Internet Options Window

4. If you click the Use Default button, your new browser home page will switch to:
http://www.msn.com/, the Microsoft Network home page.

5. If you click the Use Blank button, the Home button on your Standard Buttons Toolbar is not
available to click.

6. If you want to set your own home page, click the address field and the cursor blinks.

7. Enter the URL address you want to use for your browser home page.

Now when you click the Home button you will be taken to your self-selected home page.

Help
The Help Menu is one of the most important functions available to you as a regular user of Internet
Explorer. Whenever you have questions or difficulties with Internet Explorer, use the Help menu
to assist you with your needs.

Help Menu

Internet Explorer Help - Contents and Index
The Internet Explorer Help provides you with a wealth of information regarding the use of
Internet Explorer as a web browser.

1. From the Help Menu, choose Contents and Index.
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Internet Explorer Help Window

2. The Microsoft Internet Explorer Help window opens in the Contents view. Note that the Help
window is divided into two panes, with categories (and subcategories and topics) on the left, and
actual help content displayed towards the right.

3. Click a question mark icon, which represents a particular topic, or the title beside it in the
left frame. Note how the content changes in the right frame, presenting information on your
selected topic.

4. Book icons represent "chapters" or categories of topics. To view the contents of a particular
chapter, click the book icon or its accompanying title to view subcategories and topics.

5. Read the Help content at right. Click any blue, underlined hyperlink to “jump” to a related
topic.

6. Use the buttons at the top of the window to navigate and change views.

7. Click the back and forward buttons to navigate backward or forward through files you have
selected.

8. Click the Index tab to bring forward a card that allows you to search for help topics alpha-
betically.

9. Click the Search tab to bring forward a card that allows you to initiate a new search for a
help topic of interest.
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Tip of the Day
Select Tip of the Day from the Help menu to display a window that delivers a new tip each day
when you use Internet Explorer. This is one technique for gradually learning what is possible in
Internet Explorer.

Tip of the Day

Tour
Microsoft provides an engaging tour of Internet Explorer. Select Tour from the Help menu, click
a topic of interest, then follow the onscreen links and instructions to proceed through the tour.

Microsoft Internet Explorer Tour Window

Online Support and Send Feedback
Finally, because you are connected to the Internet through your web browser and computer, you
can connect directly with Microsoft to receive online support or to provide feedback about their
software.
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Select Online Support from the Help menu. Your browser takes you to Microsoft's Online Sup-
port Center.

Microsoft Product Support Services Icon

Select the country you are working in then select from the list of options in the pane along the
left side of the browser window.

Types of Support Options and Support Resources, Microsoft Online Support Center

Select Send Feedback to access online options for contacting Microsoft to provide feedback.

Contact Microsoft Icon

An onscreen matrix will help you select the appropriate category for feedback and guide you to
the appropriate place to submit your feedback.

As you continue your quest to become a seasoned Internet Explorer user, you will find the Internet
Explorer Help menu one of your most valuable tools.
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Closing Thoughts
Web browsers are your window to the vast content of the Internet. Developing your proficiency
using Internet Explorer will improve your ability to access, manage and utilize Internet resources to
enhance teaching and learning in your classroom and increase your professional productivity.

Resources
A list of linked web resources can be found on the Internet Explorer Resource page.
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